ramips: sync image filename with boardname
[openwrt/openwrt.git] / target / linux / ramips / image / Makefile
index c70761b250fed3a2ec3ca8d60b869b83b434db0c..ea7ce0bc90278f33904511a1bdb1a7430a17402f 100644 (file)
@@ -39,7 +39,7 @@ define Device/Default
   DEVICE_DTS_DIR := ../dts
   IMAGES := sysupgrade.bin
   IMAGE_SIZE := $(ralink_default_fw_size_8M)
-  SUPPORTED_DEVICES = $(1)
+  SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
   sysupgrade_bin := append-kernel | append-rootfs | pad-rootfs
   IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
 endef