ramips: add support for ASUS RT-AC54U
[openwrt/openwrt.git] / target / linux / ramips / image / mt7620.mk
index 4f5341f06ee4850baccd0d7eff31675eaeeef2a5..4fa8c68a8870d0912032265a297f56bcbf4a65d2 100644 (file)
@@ -86,6 +86,16 @@ define Device/asus_rt-ac51u
 endef
 TARGET_DEVICES += asus_rt-ac51u
 
+define Device/asus_rt-ac54u
+  SOC := mt7620a
+  IMAGE_SIZE := 16064k
+  DEVICE_VENDOR := Asus
+  DEVICE_MODEL := RT-AC54U
+  DEVICE_PACKAGES := kmod-mt76x2 kmod-usb2 kmod-usb-ohci \
+       kmod-usb-ledtrig-usbport
+endef
+TARGET_DEVICES += asus_rt-ac54u
+
 define Device/asus_rt-n12p
   SOC := mt7620n
   IMAGE_SIZE := 16064k