ramips: add support for ALFA Network AC1200RM
[openwrt/openwrt.git] / target / linux / ramips / image / mt7620.mk
index 796cc619a3a673be6f8b7eb6ab6726287dc13368..6f9aa1aa6d4a85e803b3228d6014e732c85af054 100644 (file)
@@ -27,6 +27,15 @@ define Device/ai-br100
 endef
 TARGET_DEVICES += ai-br100
 
+define Device/alfa-network_ac1200rm
+  DTS := AC1200RM
+  IMAGE_SIZE := 16064k
+  DEVICE_TITLE := ALFA Network AC1200RM
+  DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci
+  SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
+endef
+TARGET_DEVICES += alfa-network_ac1200rm
+
 define Device/Archer
   TPLINK_HWREVADD := 0
   TPLINK_HVERSION := 3
@@ -105,7 +114,9 @@ TARGET_DEVICES += cf-wr800n
 define Device/cs-qr10
   DTS := CS-QR10
   DEVICE_TITLE := Planex CS-QR10
-  DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-i2c-core kmod-i2c-ralink kmod-sound-core kmod-sound-mtk kmod-sdhci-mt7620
+  DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci \
+       kmod-sound-core kmod-sound-mt7620 \
+       kmod-i2c-ralink kmod-sdhci-mt7620
 endef
 TARGET_DEVICES += cs-qr10
 
@@ -139,7 +150,7 @@ define Device/dch-m225
        seama-seal -m "signature=wapn22_dlink.2013gui_dap1320b" | \
        check-size $$$$(IMAGE_SIZE)
   DEVICE_TITLE := D-Link DCH-M225
-  DEVICE_PACKAGES := kmod-mt76
+  DEVICE_PACKAGES := kmod-mt76 kmod-sound-core kmod-sound-mt7620 kmod-i2c-ralink
 endef
 TARGET_DEVICES += dch-m225
 
@@ -250,6 +261,7 @@ define Device/kng_rc
   IMAGES += factory.bin
   IMAGE/factory.bin := $$(sysupgrade_bin) | pad-to 64k | check-size $$$$(IMAGE_SIZE) | \
        zyimage -d 8997 -v "ZyXEL Keenetic Viva"
+  SUPPORTED_DEVICES := kng_rc
 endef
 TARGET_DEVICES += kng_rc
 
@@ -260,6 +272,7 @@ define Device/kn_rc
   IMAGES += factory.bin
   IMAGE/factory.bin := $$(IMAGE/sysupgrade.bin) | pad-to 64k | check-size $$$$(IMAGE_SIZE) | \
        zyimage -d 4882 -v "ZyXEL Keenetic Omni"
+  SUPPORTED_DEVICES := kn_rc
 endef
 TARGET_DEVICES += kn_rc
 
@@ -270,6 +283,7 @@ define Device/kn_rf
   IMAGES += factory.bin
   IMAGE/factory.bin := $$(IMAGE/sysupgrade.bin) | pad-to 64k | check-size $$$$(IMAGE_SIZE) | \
        zyimage -d 2102034 -v "ZyXEL Keenetic Omni II"
+  SUPPORTED_DEVICES := kn_rf
 endef
 TARGET_DEVICES += kn_rf
 
@@ -311,18 +325,21 @@ TARGET_DEVICES += mt7620a
 define Device/mt7620a_mt7530
   DTS := MT7620a_MT7530
   DEVICE_TITLE := MediaTek MT7620a + MT7530 EVB
+  SUPPORTED_DEVICES := mt7620a_mt7530
 endef
 TARGET_DEVICES += mt7620a_mt7530
 
 define Device/mt7620a_mt7610e
   DTS := MT7620a_MT7610e
   DEVICE_TITLE := MediaTek MT7620a + MT7610e EVB
+  SUPPORTED_DEVICES := mt7620a_mt7610e
 endef
 TARGET_DEVICES += mt7620a_mt7610e
 
 define Device/mt7620a_v22sg
   DTS := MT7620a_V22SG
   DEVICE_TITLE := MediaTek MT7620a V22SG
+  SUPPORTED_DEVICES := mt7620a_v22sg
 endef
 TARGET_DEVICES += mt7620a_v22sg
 
@@ -389,6 +406,12 @@ define Device/rp-n53
 endef
 TARGET_DEVICES += rp-n53
 
+define Device/rt-n12p
+  DTS := RT-N12-PLUS
+  DEVICE_TITLE := Asus RT-N11P/RT-N12+/RT-N12Eb1
+endef
+TARGET_DEVICES += rt-n12p
+
 define Device/rt-n14u
   DTS := RT-N14U
   DEVICE_TITLE := Asus RT-N14u
@@ -410,6 +433,14 @@ define Device/tiny-ac
 endef
 TARGET_DEVICES += tiny-ac
 
+define Device/vonets_var11n-300
+  DTS := VAR11N-300
+  IMAGE_SIZE := $(ralink_default_fw_size_4M)
+  BLOCKSIZE := 4k
+  DEVICE_TITLE := Vonets VAR11N-300
+endef
+TARGET_DEVICES += vonets_var11n-300
+
 define Device/whr-1166d
   DTS := WHR-1166D
   IMAGE_SIZE := 15040k