ramips: fix image validation errors
[openwrt/openwrt.git] / target / linux / ramips / image / rt305x.mk
index 6bb93519c3301e497bbd8a3fe721e3f8c13472e8..c7e18cb748efaca3e6cd69c805e0f0319e6661f8 100644 (file)
@@ -5,6 +5,7 @@
 define Device/asl26555-8M
   DTS := ASL26555-8M
   IMAGE_SIZE := 7744k
+  SUPPORTED_DEVICES := asl26555
   DEVICE_TITLE := Alpha ASL26555 
   DEVICE_PACKAGES := kmod-usb-core kmod-usb-dwc2 kmod-usb-ledtrig-usbport
 endef
@@ -14,6 +15,7 @@ TARGET_DEVICES += asl26555-8M
 define Device/asl26555-16M
   DTS := ASL26555-16M
   IMAGE_SIZE := 15872k
+  SUPPORTED_DEVICES := asl26555
   DEVICE_TITLE := Alpha ASL26555 16M
   DEVICE_PACKAGES :=
 endef
@@ -23,6 +25,7 @@ TARGET_DEVICES += asl26555-16M
 define Device/nixcore-8M
   DTS := NIXCORE-8M
   IMAGE_SIZE := 7872k
+  SUPPORTED_DEVICES := nixcore-x1
   DEVICE_TITLE := NixcoreX1 8M
   DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-i2c-core kmod-i2c-ralink kmod-spi-dev
 endef
@@ -32,6 +35,7 @@ TARGET_DEVICES += nixcore-8M
 define Device/nixcore-16M
   DTS := NIXCORE-16M
   IMAGE_SIZE := 16064k
+  SUPPORTED_DEVICES := nixcore-x1
   DEVICE_TITLE := NixcoreX1 16M
   DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-i2c-core kmod-i2c-ralink kmod-spi-dev
 endef
@@ -41,6 +45,7 @@ TARGET_DEVICES += nixcore-16M
 define Device/vocore-8M
   DTS := VOCORE-8M
   IMAGE_SIZE := 7872k
+  SUPPORTED_DEVICES := vocore
   DEVICE_TITLE :=  VoCore 8M
   DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 \
                kmod-i2c-core kmod-i2c-ralink \
@@ -52,6 +57,7 @@ TARGET_DEVICES += vocore-8M
 define Device/vocore-16M
   DTS := VOCORE-16M
   IMAGE_SIZE := 16064k
+  SUPPORTED_DEVICES := vocore
   DEVICE_TITLE := VoCore 16M
   DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 \
                kmod-i2c-core kmod-i2c-ralink \
@@ -88,12 +94,12 @@ endef
 TARGET_DEVICES += atp-52b
 
 
-define Device/f5d8235v2
+define Device/f5d8235-v2
   DTS := F5D8235_V2
   IMAGE_SIZE := 7744k
   DEVICE_TITLE := Belkin F5D8235 v2
 endef
-TARGET_DEVICES += f5d8235v2
+TARGET_DEVICES += f5d8235-v2
 
 
 define Device/f7c027
@@ -121,13 +127,13 @@ endef
 TARGET_DEVICES += awm003-evb
 
 
-define Device/awmapn2403
+define Device/awapn2403
   DTS := AWAPN2403
   BLOCKSIZE := 4k
   IMAGE_SIZE := $(ralink_default_fw_size_4M)
   DEVICE_TITLE := AsiaRF AWAPN2403
 endef
-TARGET_DEVICES += awmapn2403
+TARGET_DEVICES += awapn2403
 
 
 define Device/bc2
@@ -168,6 +174,15 @@ endef
 TARGET_DEVICES += dir-620-d1
 
 
+define Device/dwr-512-b
+  DTS := DWR-512-B
+  DEVICE_TITLE := D-Link DWR-512 B
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-i2c-core kmod-i2c-ralink kmod-spi-dev \
+                       kmod-usb-serial kmod-usb-serial-option kmod-usb-serial-wwan comgt
+endef
+TARGET_DEVICES += dwr-512-b
+
+
 define Device/esr-9753
   DTS := ESR-9753
   BLOCKSIZE := 64k
@@ -301,13 +316,13 @@ endef
 TARGET_DEVICES += mzk-wdpr
 
 
-define Device/ncs601W
+define Device/ncs601w
   DTS := NCS601W
   DEVICE_TITLE := Wansview NCS601W
   DEVICE_PACKAGES := kmod-video-core kmod-video-uvc \
                kmod-usb-core kmod-usb-ohci
 endef
-TARGET_DEVICES += ncs601W
+TARGET_DEVICES += ncs601w
 
 
 define Device/m2m
@@ -429,13 +444,13 @@ endef
 TARGET_DEVICES += w502u
 
 
-define Device/wcr150gn
+define Device/wcr-150gn
   DTS := WCR150GN
   BLOCKSIZE := 64k
   IMAGE_SIZE := $(ralink_default_fw_size_4M)
   DEVICE_TITLE := Sparklan WCR-150GN
 endef
-TARGET_DEVICES += wcr150gn
+TARGET_DEVICES += wcr-150gn
 
 
 define Device/mzk-dp150n
@@ -448,12 +463,12 @@ endef
 TARGET_DEVICES += mzk-dp150n
 
 
-define Device/wizard-8800
+define Device/wizard8800
   DTS := WIZARD8800
   UIMAGE_NAME:= Linux Kernel Image
   DEVICE_TITLE := EasyAcc WIZARD 8800
 endef
-TARGET_DEVICES += wizard-8800
+TARGET_DEVICES += wizard8800
 
 
 define Device/wizfi630a