ramips: add support for D-Link DWR-116-A1/2
[openwrt/openwrt.git] / target / linux / ramips / image / rt3883.mk
index abece505d7e7efdf05a785cab8974391b02c5e74..f90fc6154fdae04f96d6faf832dbc3a7c62f375e 100644 (file)
@@ -1,6 +1,9 @@
 #
 # RT3662/RT3883 Profiles
 #
+define Build/mkrtn56uimg
+       $(STAGING_DIR_HOST)/bin/mkrtn56uimg $(1) $@
+endef
 
 define Device/br-6475nd
   DTS := BR-6475ND
@@ -66,6 +69,16 @@ endef
 TARGET_DEVICES += hpm
 
 
+define Device/rt-n56u
+  DTS := RT-N56U
+  BLOCKSIZE := 64k
+  IMAGE/sysupgrade.bin += | mkrtn56uimg -s
+  DEVICE_TITLE := Asus RT-N56U
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig
+endef
+TARGET_DEVICES += rt-n56u
+
+
 define Device/tew-691gr
   DTS := TEW-691GR
   BLOCKSIZE := 64k
@@ -101,3 +114,11 @@ define Device/wlr-6000
   DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig
 endef
 TARGET_DEVICES += wlr-6000
+
+
+define Device/wmdr-143n
+  DTS := WMDR-143N
+  BLOCKSIZE := 64k
+  DEVICE_TITLE := Loewe WMDR-143N
+endef
+TARGET_DEVICES += wmdr-143n