lantiq_dsl.sh: properly detect vdsl_cpe_control and add missing quotes
[openwrt/openwrt.git] / target / linux / rb532 / modules.mk
index abf9f72a648f19e59d17b012ed54a753530d6931..0cbbdab3ea24d71bc49b69884bc20417fd01b12f 100644 (file)
@@ -13,8 +13,8 @@ define KernelPackage/ata-rb532-cf
        CONFIG_PATA_PLATFORM \
        CONFIG_PATA_RB532
   FILES:=\
-       $(LINUX_DIR)/drivers/ata/pata_platform.$(LINUX_KMOD_SUFFIX) \
-       $(LINUX_DIR)/drivers/ata/pata_rb532_cf.$(LINUX_KMOD_SUFFIX)
+       $(LINUX_DIR)/drivers/ata/pata_platform.ko \
+       $(LINUX_DIR)/drivers/ata/pata_rb532_cf.ko
   AUTOLOAD:=$(call AutoLoad,41,pata_platform pata_rb532_cf,1)
   $(call AddDepends/ata)
 endef
@@ -33,7 +33,7 @@ define KernelPackage/input-rb532
   KCONFIG:= \
        CONFIG_INPUT_MISC=y \
        CONFIG_INPUT_RB532_BUTTON
-  FILES:=$(LINUX_DIR)/drivers/input/misc/rb532_button.$(LINUX_KMOD_SUFFIX)
+  FILES:=$(LINUX_DIR)/drivers/input/misc/rb532_button.ko
   AUTOLOAD:=$(call AutoLoad,62,rb532_button)
   $(call AddDepends/input)
 endef