enable start-stop-daemon by default, i want to use this to clean up a few init script...
[openwrt/openwrt.git] / target / linux / rdc-2.6 / Makefile
index d52974ffae905bc6aa464c3352a2dc77214c268a..5af5e85c6eb51fa84f8e0ca61109c37bc07d8686 100644 (file)
@@ -8,23 +8,27 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=i386
 BOARD:=rdc
-BOARDNAME:=RDC x86
-FEATURES:=squashfs jffs2 pci broken
+BOARDNAME:=RDC321x x86
+FEATURES:=squashfs jffs2 broken
 
-LINUX_VERSION:=2.6.21.5
+LINUX_VERSION:=2.6.22.4
 
 define Target/Description
-        Build firmware images for RDC3211 based routers
-        (e.g. Airlink101 AR525W, Linksys WRT54R)
+        Build firmware images for RDC321x based routers
+        (e.g. Airlink101 AR525W, Linksys WRT54R, Sitecom WL-153)
 endef
 
 include $(INCLUDE_DIR)/kernel-build.mk
 
 ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
     define Kernel/SetInitramfs
-       rm -f $(BUILD_DIR)/root/sbin/init
-       ln -s /etc/preinit $(BUILD_DIR)/root/sbin/init
-       $(CP) $(PLATFORM_DIR)/image/preinit.arch $(BUILD_DIR)/root/etc/
+       echo "r6040 parent=wlan0" > $(TARGET_DIR)/etc/modules.d/99-r6040
+       $(RM) $(TARGET_DIR)/sbin/init
+       ln -s /etc/preinit $(TARGET_DIR)/sbin/init
+       sed -i 's,exec /sbin/init,exec /bin/busybox init,g' $(TARGET_DIR)/etc/preinit
+       sed -i 's,/sbin/init,/bin/busybox init,g' $(TARGET_DIR)/init
+       mv $(TARGET_DIR)/init $(TARGET_DIR)/linuxrc
+       sed -i 's,eth0,eth1,g' $(TARGET_DIR)/etc/config/network
     endef
 endif