clean up a few things in image build makefiles and fix unnecessary grub rebuilds
[openwrt/openwrt.git] / target / linux / rdc-2.6 / image / Makefile
index 06082404ee7c6aeca838d8e66e93ea162a17b1c0..f8398baadb98c2e1109c14ed564c0799c05b81b1 100644 (file)
@@ -7,19 +7,13 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
-define Build/Clean
-endef
-
-define Image/Prepare
-endef
-
 define Image/Prepare
-        cat $(KDIR)/vmlinux | $(STAGING_DIR)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
+       $(CP) $(LINUX_DIR)/arch/i386/boot/bzImage $(KDIR)/bzImage
 endef
 
-define Image/Build/ar525w
+define Image/Build
+       touch $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img
+       $(STAGING_DIR)/bin/airlink -b 0 -j $(KDIR)/bzImage $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img
 endef
 
-$(call Image/Build/ar525w,$(1),$(patsubst jffs2-%,jffs2,$(1)))
-
 $(eval $(call BuildImage))