bump to 3.3.8
[openwrt/openwrt.git] / target / linux / rdc / Makefile
index c4bfd66c04165d92a66b47807a102c8d36aedaae..117afb7bb06416ba9d275509f97e8e4a5d5a345e 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,15 +9,18 @@ include $(TOPDIR)/rules.mk
 ARCH:=i386
 BOARD:=rdc
 BOARDNAME:=RDC 321x
-FEATURES:=squashfs jffs2 pci usb pcmcia
-CFLAGS:=-Os -pipe -march=i486 -funit-at-a-time
-SUBTARGETS:=amit ar525w r8610 dir-450
+FEATURES:=squashfs jffs2 pci usb pcmcia broken
+CFLAGS:=-Os -pipe -march=i486 -mtune=i486 -fno-caller-saves
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=3.3.8
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += hostapd-mini kmod-rdc321x-wdt kmod-r6040
+DEFAULT_PACKAGES += kmod-llc kmod-stp kmod-bridge kmod-8021q \
+                   wpad-mini kmod-libphy kmod-r6040 kmod-input-core \
+                   kmod-input-polldev kmod-input-gpio-buttons kmod-button-hotplug \
+                   kmod-rdc321x-wdt
 
 define Target/Description
         Build firmware images for RDC321x based routers
@@ -25,7 +28,3 @@ define Target/Description
 endef
 
 $(eval $(call BuildTarget))
-
-$(eval $(call RequireCommand,lzma, \
-        Please install lzma-4.4x. \
-))