update to 2.6.32.29
[openwrt/openwrt.git] / target / linux / sibyte / Makefile
index 52728da1906ae71ef2e51b28161a85e17a454471..9de993ebd1f6b3f54f4ddd3891a218031e9496cb 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,11 +8,17 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mips
 BOARD:=sibyte
-BOARDNAME:=SiByte MIPS
-FEATURES:=broken
+BOARDNAME:=Broadcom/SiByte SB-1
+FEATURES:=fpu
+CFLAGS:=-Os -pipe -march=sb1 -funit-at-a-time
+MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.21.5
+LINUX_VERSION:=2.6.32.29
 
 include $(INCLUDE_DIR)/target.mk
 
+define Target/Description
+       Build firmware images for Broadcom/SiByte SB-1 boards
+endef
+
 $(eval $(call BuildTarget))