mvebu: add Armada 385 DB AP support
[openwrt/openwrt.git] / target / linux / sibyte / Makefile
index 57a50e138bd2d4eb542acdee55bbdcdf669a9350..a98b170f59f49aecdae5a6fee5f427a21f03ae5a 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,10 +9,12 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=sibyte
 BOARDNAME:=Broadcom/SiByte SB-1
-FEATURES:=fpu
-CFLAGS:=-Os -pipe -march=sb1 -funit-at-a-time
+FEATURES:=fpu ramdisk broken
+CPU_TYPE:=sb1
+CPU_CFLAGS_sb1:=-march=sb1
+MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.32.24
+KERNEL_PATCHVER:=3.3
 
 include $(INCLUDE_DIR)/target.mk