sunxi: clean up modules definitions
[openwrt/openwrt.git] / target / linux / sunxi / Makefile
index e60f55036034df2dda9a723ac0e3b5c2600583d9..3c2f14b8418e1d296a239027f6fdee9b5ba8f9b2 100644 (file)
@@ -1,22 +1,33 @@
 #
-# Copyright (C) 2013 OpenWrt.org
+# Copyright (C) 2013-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
+
 include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=sunxi
-BOARDNAME:=Allwinner SoC
-FEATURES:=targz
-SUBTARGETS=cortex-a7 cortex-a8
-MAINTAINER:=Luka Perkov <luka@openwrt.org>
+BOARDNAME:=Allwinner A1x/A20/A3x
+FEATURES:=fpu usb ext4 display rtc squashfs
+CPU_TYPE:=cortex-a8
+CPU_SUBTYPE:=vfpv3
+MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
+
+KERNEL_PATCHVER:=4.4
+KERNELNAME:=zImage dtbs
 
-LINUX_VERSION:=3.10.18
+# A10: Cortex-A8
+# A13: Cortex-A8
+# A20: dual Cortex-A7
+# A31: quad Cortex-A7
+# A80: octa Cortex-A15/A7
+# H3: quad Cortex-A7
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:="zImage dtbs"
+DEFAULT_PACKAGES += uboot-envtools
+DEFAULT_PACKAGES += mkf2fs e2fsprogs
 
 $(eval $(call BuildTarget))