sunxi: tidy up and sort alphabetically in image Makefiles
[openwrt/openwrt.git] / target / linux / sunxi / image / Makefile
index f1990436398ea837ae916fbbee4ade7c01373f04..705d409ac5e5e8e81c8b39055554e6b19be4acb6 100644 (file)
@@ -1,5 +1,6 @@
 #
-# Copyright (C) 2013 OpenWrt.org
+# Copyright (C) 2013-2016 OpenWrt.org
+# Copyright (C) 2016 Yousong Zhou
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,38 +8,50 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
-BOARDS:= \
-       sun4i-a10-cubieboard \
-       sun4i-a10-olinuxino-lime \
-       sun4i-a10-pcduino \
-       sun5i-a13-olinuxino \
-       sun7i-a20-cubieboard2 \
-       sun7i-a20-cubietruck \
-       sun7i-a20-olinuxino-micro
-
-define Image/BuildKernel
-       mkimage -A arm -O linux -T kernel -C none \
-               -a 0x40008000 -e 0x40008000 \
-               -n 'ARM OpenWrt Linux-$(LINUX_VERSION)' \
-               -d $(KDIR)/zImage $(BIN_DIR)/$(IMG_PREFIX)-uImage
-       
-    ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
-       $(CP) $(KDIR)/zImage-initramfs $(BIN_DIR)/$(IMG_PREFIX)-zImage-initramfs
-       echo -ne '\x00\x00\x00\x00' >> $(BIN_DIR)/$(IMG_PREFIX)-zImage-initramfs
-       $(call Image/BuildKernel/MkuImage, \
-               none, 0x40008000, 0x40008000, \
-               $(BIN_DIR)/$(IMG_PREFIX)-zImage-initramfs, \
-               $(BIN_DIR)/$(IMG_PREFIX)-uImage-initramfs \
-       )
-    endif
-
-       $(foreach board,$(BOARDS),
-               $(CP) $(LINUX_DIR)/arch/arm/boot/dts/$(board).dtb $(BIN_DIR)/
-       )
+FAT32_BLOCK_SIZE=1024
+FAT32_BLOCKS=$(shell echo $$(($(CONFIG_SUNXI_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
+
+KERNEL_LOADADDR:=0x40008000
+
+define Build/sunxi-sdcard
+       rm -f $@.boot
+       mkfs.fat $@.boot -C $(FAT32_BLOCKS)
+
+       mcopy -i $@.boot $(STAGING_DIR_IMAGE)/$(DEVICE_NAME)-boot.scr ::boot.scr
+       mcopy -i $@.boot $(DTS_DIR)/$(SUNXI_DTS).dtb ::dtb
+       mcopy -i $@.boot $(IMAGE_KERNEL) ::uImage
+       ./gen_sunxi_sdcard_img.sh $@ \
+               $@.boot \
+               $(IMAGE_ROOTFS) \
+               $(CONFIG_SUNXI_SD_BOOT_PARTSIZE) \
+               $(CONFIG_TARGET_ROOTFS_PARTSIZE) \
+               $(STAGING_DIR_IMAGE)/$(DEVICE_NAME)-u-boot-with-spl.bin
+       rm -f $@.boot
 endef
 
-define Image/Build
-       $(call Image/Build/$(1),$(1))
+# why \x00\x00\x00\x00 for zImage-initramfs
+define Device/Default
+  PROFILES := Default
+  DEVICE_VARS := SUNXI_DTS SUNXI_DTS_DIR SUNXI_UBOOT
+  KERNEL_NAME := zImage
+  KERNEL := kernel-bin | uImage none
+  IMAGES := sdcard.img.gz
+  IMAGE/sdcard.img.gz := sunxi-sdcard | append-metadata | gzip
+  SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
+  SUNXI_DTS_DIR :=
+  SUNXI_DTS = $$(SUNXI_DTS_DIR)$$(SOC)-$(lastword $(subst _, ,$(1)))
 endef
 
+ifeq ($(SUBTARGET),cortexa7)
+include cortex-a7.mk
+endif
+
+ifeq ($(SUBTARGET),cortexa8)
+include cortex-a8.mk
+endif
+
+ifeq ($(SUBTARGET),cortexa53)
+include cortex-a53.mk
+endif
+
 $(eval $(call BuildImage))