sunxi: add default network config for missing boards
[openwrt/openwrt.git] / target / linux / sunxi / modules.mk
index 9a4782ddf27464cb02defa9cd5c4a6aee51d7125..a8339211caf391e2ba1b270a68558595c53c5d20 100644 (file)
@@ -66,3 +66,19 @@ endef
 
 $(eval $(call KernelPackage,sun4i-emac))
 
+
+define KernelPackage/wdt-sunxi
+    SUBMENU:=$(OTHER_MENU)
+    TITLE:=AllWinner sunXi Watchdog timer
+    DEPENDS:=@TARGET_sunxi
+    KCONFIG:=CONFIG_SUNXI_WATCHDOG
+    FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/sunxi_wdt.ko
+    AUTOLOAD:=$(call AutoLoad,51,sunxi_wdt)
+endef
+
+define KernelPackage/wdt-sunxi/description
+    Kernel module for AllWinner sunXi watchdog timer.
+endef
+
+$(eval $(call KernelPackage,wdt-sunxi))
+