tegra: add vendor string to device name
[openwrt/openwrt.git] / target / linux / tegra / image / Makefile
index 706cc65d92e86a91212c3c71b7c9f2e80bf47078..c1aa81beddc5b44a30b5c87a3b7b54f6603ffdcf 100644 (file)
@@ -44,16 +44,16 @@ define Device/Default
   KERNEL_NAME := zImage
   KERNEL := kernel-bin
   PROFILES := Default
+  SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
 endef
 
-define Device/trimslice
+define Device/compulab_trimslice
   DEVICE_TITLE := CompuLab TrimSlice
   DEVICE_DTS := tegra20-trimslice
   DEVICE_PACKAGES := kmod-r8169 kmod-rt2800-usb kmod-rtc-em3027 \
        kmod-usb-storage wpad-mini
-  SUPPORTED_DEVICES := compulab,trimslice
   UBOOT := trimslice-mmc
 endef
-TARGET_DEVICES += trimslice
+TARGET_DEVICES += compulab_trimslice
 
 $(eval $(call BuildImage))