switch to kernel 3.6.6
[openwrt/openwrt.git] / target / linux / uml / Makefile
index 3dd9a986ab4d86ef6a5d2c887433884f82a7ce7d..6c7f934728b7d07296f6b7d4e772355cfc980e9a 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -20,13 +20,17 @@ ARCH:=$(shell uname -m | sed \
 )
 BOARD:=uml
 BOARDNAME:=User Mode Linux
-FEATURES:=ext2
-LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
+FEATURES:=ext4 audio
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=2.6.26.2
+LINUX_VERSION:=3.6.6
 
 include $(INCLUDE_DIR)/target.mk
 
+LINUX_TARGET_CONFIG:=$(CURDIR)/config/$(ARCH)
+
+DEFAULT_PACKAGES += wpad-mini kmod-mac80211-hwsim
+
 endif
 
 $(eval $(call BuildTarget))