kernel: also update the targets to use 3.2.15
[openwrt/openwrt.git] / target / linux / uml / Makefile
index 022098a8383f8145799646427f28824674da66d3..ee8758eed990736137d991be1bed672619600ca7 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -20,13 +20,17 @@ ARCH:=$(shell uname -m | sed \
 )
 BOARD:=uml
 BOARDNAME:=User Mode Linux
-FEATURES:=broken ext2
-LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
+FEATURES:=ext4 audio
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=2.6.24.7
+LINUX_VERSION:=3.2.15
 
 include $(INCLUDE_DIR)/target.mk
 
+LINUX_TARGET_CONFIG:=$(CURDIR)/config/$(ARCH)
+
+DEFAULT_PACKAGES += wpad-mini kmod-mac80211-hwsim
+
 endif
 
 $(eval $(call BuildTarget))