x86: enable mkf2fs and e2fsprogs by default
[openwrt/openwrt.git] / target / linux / x86 / Makefile
index 7040636ddffa6e79a9fdc14aa3f41699185d2a5b..218b92487b3f4a6c3219352d97b3b6a28f92c6c7 100644 (file)
@@ -13,14 +13,14 @@ FEATURES:=squashfs ext4 vdi vmdk pcmcia targz fpu
 SUBTARGETS=generic legacy xen_domu geode 64
 MAINTAINER:=Felix Fietkau <nbd@nbd.name>
 
 SUBTARGETS=generic legacy xen_domu geode 64
 MAINTAINER:=Felix Fietkau <nbd@nbd.name>
 
-DEFAULT_PACKAGES += partx-utils
-
 KERNEL_PATCHVER:=4.4
 
 KERNELNAME:=bzImage
 
 include $(INCLUDE_DIR)/target.mk
 
 KERNEL_PATCHVER:=4.4
 
 KERNELNAME:=bzImage
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES += partx-utils mkf2fs e2fsprogs
+
 $(eval $(call BuildTarget))
 
 $(eval $(call $(if $(CONFIG_TARGET_ROOTFS_ISO),RequireCommand,Ignore),mkisofs, \
 $(eval $(call BuildTarget))
 
 $(eval $(call $(if $(CONFIG_TARGET_ROOTFS_ISO),RequireCommand,Ignore),mkisofs, \