kernel: update kernel 4.4 to version 4.4.6
[openwrt/openwrt.git] / target / linux / x86 / Makefile
index ae10d165adf5275fea22fb18e2e92c239a5fbd93..45bb8c7cac25a5f3565fbd0c36a893300bdcda02 100644 (file)
@@ -1,21 +1,25 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
 
-ARCH=i386
+ARCH:=i386
 BOARD:=x86
 BOARDNAME:=x86
-FEATURES:=squashfs jffs2 ext2
-SUBTARGETS=generic
+FEATURES:=squashfs ext4 vdi vmdk pcmcia targz
+SUBTARGETS=generic xen_domu ep80579 geode kvm_guest 64
+MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
 
-LINUX_VERSION:=2.6.24.5
+DEFAULT_PACKAGES += partx-utils
+
+KERNEL_PATCHVER:=4.4
+
+KERNELNAME:=bzImage
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci
 
 $(eval $(call BuildTarget))