x86: remove subtarget specific LINUX_VERSION overrides
[openwrt/openwrt.git] / target / linux / x86 / Makefile
index 4a7cdd615f94c32d58ce6554d19fda023576b8b7..aaa9e02a2bf2cc21d0c4325f30b6d4bebc07087a 100644 (file)
@@ -1,21 +1,20 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
 
-ARCH=i386
+ARCH:=i386
 BOARD:=x86
 BOARDNAME:=x86
-FEATURES:=squashfs jffs2 ext2
-SUBTARGETS=generic mediacenter
+FEATURES:=squashfs jffs2 ext4 vdi vmdk pcmcia targz
+SUBTARGETS=generic olpc xen_domu ep80579 net5501 kvm_guest geos alix2 thincan
 
-LINUX_VERSION:=2.6.24.2
+LINUX_VERSION:=3.3.6
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci
 
 $(eval $(call BuildTarget))