We are now at .23.1
[openwrt/openwrt.git] / target / linux / x86 / Makefile
index ddb50e64046b894ee4b2e1acf05bad5eaf5f2d5f..ab23e9f7958a7dbcee7dfed4345944a22215b4a1 100644 (file)
@@ -10,15 +10,15 @@ ARCH=i386
 BOARD:=x86
 BOARDNAME:=x86
 FEATURES:=squashfs jffs2 ext2
+SUBTARGETS=generic mediacenter
 
-LINUX_VERSION:=2.6.22.4
+LINUX_VERSION:=2.6.23.1
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci
 
-$(eval $(call Target,generic))
-$(eval $(call Target,mediacenter))
 $(eval $(call BuildTarget))
-$(eval $(call RequireCommand,mkisofs, \
+
+$(eval $(call $(if $(CONFIG_TARGET_ROOTFS_ISO),RequireCommand,Ignore),mkisofs, \
        Please install mkisofs. \
 ))