x86: remove the xen_domu subtarget
[openwrt/openwrt.git] / target / linux / x86 / Makefile
index 1eae227f858fadfd463e84c7a63e73d024f6fb54..f371b2ba3a022b6124d04b8e6e8fbac0727d0a95 100644 (file)
@@ -9,11 +9,9 @@ include $(TOPDIR)/rules.mk
 ARCH:=i386
 BOARD:=x86
 BOARDNAME:=x86
-FEATURES:=squashfs ext4 vdi vmdk pcmcia targz
-SUBTARGETS=generic xen_domu geode 64
-MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
-
-DEFAULT_PACKAGES += partx-utils
+FEATURES:=squashfs ext4 vdi vmdk pcmcia targz fpu
+SUBTARGETS:=generic legacy geode 64
+MAINTAINER:=Felix Fietkau <nbd@nbd.name>
 
 KERNEL_PATCHVER:=4.4
 
@@ -21,6 +19,8 @@ KERNELNAME:=bzImage
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES += partx-utils mkf2fs e2fsprogs
+
 $(eval $(call BuildTarget))
 
 $(eval $(call $(if $(CONFIG_TARGET_ROOTFS_ISO),RequireCommand,Ignore),mkisofs, \