x86: remove the xen_domu subtarget
[openwrt/openwrt.git] / target / linux / x86 / Makefile
index 52d9885e5c6e2bc0bec7e1eb49537292e8be5151..f371b2ba3a022b6124d04b8e6e8fbac0727d0a95 100644 (file)
@@ -9,16 +9,18 @@ include $(TOPDIR)/rules.mk
 ARCH:=i386
 BOARD:=x86
 BOARDNAME:=x86
-FEATURES:=squashfs ext4 vdi vmdk pcmcia targz
-SUBTARGETS=generic olpc xen_domu ep80579 net5501 kvm_guest geos alix2 thincan \
-          rdc
+FEATURES:=squashfs ext4 vdi vmdk pcmcia targz fpu
+SUBTARGETS:=generic legacy geode 64
+MAINTAINER:=Felix Fietkau <nbd@nbd.name>
 
-KERNEL_PATCHVER:=3.14
+KERNEL_PATCHVER:=4.4
 
 KERNELNAME:=bzImage
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES += partx-utils mkf2fs e2fsprogs
+
 $(eval $(call BuildTarget))
 
 $(eval $(call $(if $(CONFIG_TARGET_ROOTFS_ISO),RequireCommand,Ignore),mkisofs, \