x86: remove the ep80579 subtarget, it has been unmaintained for a long time
[openwrt/openwrt.git] / target / linux / x86 / Makefile
index 452065c3824ba21447db18634bffc4853b506fc7..1e51d7117e97b0e5939e5e47542b1788cd5bc4fa 100644 (file)
@@ -1,24 +1,28 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
 
-ARCH=i386
+ARCH:=i386
 BOARD:=x86
 BOARDNAME:=x86
-FEATURES:=squashfs jffs2 ext2
+FEATURES:=squashfs ext4 vdi vmdk pcmcia targz
+SUBTARGETS=generic xen_domu geode kvm_guest 64
+MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
+
+DEFAULT_PACKAGES += partx-utils
 
-LINUX_VERSION:=2.6.23
+KERNEL_PATCHVER:=4.4
+
+KERNELNAME:=bzImage
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci
 
-$(eval $(call Target,generic))
-$(eval $(call Target,mediacenter))
 $(eval $(call BuildTarget))
+
 $(eval $(call $(if $(CONFIG_TARGET_ROOTFS_ISO),RequireCommand,Ignore),mkisofs, \
        Please install mkisofs. \
 ))