ramips: remove generic profiles
[openwrt/openwrt.git] / target / linux / x86 / Makefile
index 6b248f68c3a0878020691ac88ea76419cc98db62..f6b037b8862e54f4c38ad949b2bb1d0234f8a5cb 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,15 +9,23 @@ include $(TOPDIR)/rules.mk
 ARCH:=i386
 BOARD:=x86
 BOARDNAME:=x86
-FEATURES:=squashfs jffs2 ext2 vdi vmdk pcmcia tgz
-SUBTARGETS=generic olpc xen_domu ep80579 net5501
+FEATURES:=squashfs ext4 vdi vmdk pcmcia targz fpu boot-part rootfs-part
+SUBTARGETS:=generic legacy geode 64
 
-LINUX_VERSION:=2.6.32.10
+KERNEL_PATCHVER:=5.4
+KERNEL_TESTING_PATCHVER:=5.4
+
+KERNELNAME:=bzImage
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES += partx-utils mkf2fs e2fsprogs kmod-button-hotplug
+
 $(eval $(call BuildTarget))
 
-$(eval $(call $(if $(CONFIG_TARGET_ROOTFS_ISO),RequireCommand,Ignore),mkisofs, \
-       Please install mkisofs. \
+$(eval $(call $(if $(CONFIG_ISO_IMAGES),SetupHostCommand,Ignore),mkisofs, \
+       Please install mkisofs. , \
+       mkisofs -v 2>&1 , \
+       genisoimage -v 2>&1 | grep genisoimage, \
+       xorrisofs -v 2>&1 | grep xorriso \
 ))