x86: enable fpu for all subtargets
[openwrt/openwrt.git] / target / linux / x86 / generic / target.mk
index 7191292e81c17001ff31bca666ab3919810eea22..90586f56d6a730908964849fdc89e43d28e58861 100644 (file)
@@ -1,7 +1,11 @@
 BOARDNAME:=Generic
+CPU_TYPE :=pentium4
+FEATURES += audio pci pcie usb
+DEFAULT_PACKAGES += kmod-button-hotplug
 
 define Target/Description
-       Build firmware images for x86 based boards
-       (e.g : Soekris, ...)
+       Build firmware images for modern x86 based boards with CPUs
+       supporting at least the Intel Pentium 4 instruction set with
+       MMX, SSE and SSE2.
 endef