target/linux/x86/image: add explicit prefix to grub-mkimage command
[openwrt/openwrt.git] / target / linux / x86 / image / Makefile
index 99887cb32b723bb35cf6257c3543b0c06984be1c..965737ac631f3867c0d36963a86f7729ae25bd26 100644 (file)
@@ -68,6 +68,7 @@ ifneq ($(CONFIG_GRUB_IMAGES),)
        $(INSTALL_DIR) $(KDIR)/root.grub/boot/grub $(KDIR)/grub2
        $(CP) $(KDIR)/bzImage $(KDIR)/root.grub/boot/vmlinuz
        grub-mkimage \
+               -p /boot/grub \
                -d $(STAGING_DIR_HOST)/lib/grub/i386-pc \
                -o $(KDIR)/grub2/core.img \
                -O i386-pc \
@@ -106,6 +107,7 @@ define Image/Build/iso
        $(INSTALL_DIR) $(KDIR)/root.grub/boot/grub $(KDIR)/grub2
        $(CP) $(KDIR)/bzImage $(KDIR)/root.grub/boot/vmlinuz
        grub-mkimage \
+               -p /boot/grub \
                -d $(STAGING_DIR_HOST)/lib/grub/i386-pc \
                -o $(KDIR)/grub2/eltorito.img \
                -O i386-pc \