build: enable gzipping of images on x86 even if ext4 is disabled
[openwrt/openwrt.git] / target / linux / x86 / image / Makefile
index ca5d0123c718f34d776ecd230ab84e83c63dde3d..d3005d79c3f2d7379dc2ee25786cf9a52ead116d 100644 (file)
@@ -153,11 +153,9 @@ ifneq ($(CONFIG_TARGET_IMAGES_GZIP),)
   define Image/Build/gzip/ext4
        $(call Image/Build/gzip,ext4)
   endef
-  ifneq ($(CONFIG_TARGET_IMAGES_PAD),)
-    define Image/Build/gzip/squashfs
+  define Image/Build/gzip/squashfs
        $(call Image/Build/gzip,squashfs)
-    endef
-  endif
+  endef
 endif
 
 define Image/BuildKernel