x86: use qemu-image command from image-commands.mk
[openwrt/openwrt.git] / target / linux / x86 / image / Makefile
index 6db12fca1ccf6c907874112f5d3adabe3d453b83..dfa1742d5a23c198828870f329a9b535391b6ba1 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006-2012 OpenWrt.org
+#
+# Copyright (C) 2006-2020 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
-export PATH=$(TARGET_PATH):/sbin
-
+GRUB2_VARIANT =
 GRUB_TERMINALS =
 GRUB_SERIAL_CONFIG =
 GRUB_TERMINAL_CONFIG =
 GRUB_CONSOLE_CMDLINE =
 
-ifneq ($(CONFIG_X86_GRUB_CONSOLE),)
+ifneq ($(strip $(foreach subtarget,$(USE_ATKBD),$(CONFIG_TARGET_x86_$(subtarget)))),)
+  GRUB2_VARIANT := generic
+else
+  GRUB2_VARIANT := legacy
+endif
+
+ifneq ($(CONFIG_GRUB_CONSOLE),)
   GRUB_CONSOLE_CMDLINE += console=tty0
   GRUB_TERMINALS += console
 endif
 
-ifneq ($(CONFIG_X86_GRUB_SERIAL),)
-  GRUB_CONSOLE_CMDLINE += console=$(call qstrip,$(CONFIG_X86_GRUB_SERIAL)),$(CONFIG_X86_GRUB_BAUDRATE)n8
-  GRUB_SERIAL_CONFIG := serial --unit=0 --speed=$(CONFIG_X86_GRUB_BAUDRATE) --word=8 --parity=no --stop=1
+GRUB_SERIAL:=$(call qstrip,$(CONFIG_GRUB_SERIAL))
+
+ifneq ($(GRUB_SERIAL),)
+  GRUB_CONSOLE_CMDLINE += console=$(GRUB_SERIAL),$(CONFIG_GRUB_BAUDRATE)n8$(if $(CONFIG_GRUB_FLOWCONTROL),r,)
+  GRUB_SERIAL_CONFIG := serial --unit=0 --speed=$(CONFIG_GRUB_BAUDRATE) --word=8 --parity=no --stop=1 --rtscts=$(if $(CONFIG_GRUB_FLOWCONTROL),on,off)
   GRUB_TERMINALS += serial
 endif
 
 ifneq ($(GRUB_TERMINALS),)
-  GRUB_TERMINAL_CONFIG := terminal --timeout=2 $(GRUB_TERMINALS)
+  GRUB_TERMINAL_CONFIG := terminal_input $(GRUB_TERMINALS); terminal_output $(GRUB_TERMINALS)
 endif
 
 ROOTPART:=$(call qstrip,$(CONFIG_TARGET_ROOTFS_PARTNAME))
+ROOTPART:=$(if $(ROOTPART),$(ROOTPART),PARTUUID=$(IMG_PART_SIGNATURE)-02)
 
-GRUB_TIMEOUT:=$(call qstrip,$(CONFIG_X86_GRUB_TIMEOUT))
-
-ifneq ($(CONFIG_X86_GRUB_IMAGES),)
-
-  BOOTOPTS:=$(call qstrip,$(CONFIG_X86_GRUB_BOOTOPTS))
-
-  define Image/cmdline/ext4
-    root=$(ROOTPART) rootfstype=ext4 rootwait
-  endef
-  
-  define Image/cmdline/jffs2-64k
-    block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=jffs2 rootwait
-  endef
-
-  define Image/cmdline/jffs2-128k
-    block2mtd.block2mtd=$(ROOTPART),131072,rootfs root=/dev/mtdblock0 rootfstype=jffs2 rootwait
-  endef
-
-  define Image/cmdline/squashfs
-    block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=squashfs rootwait
-  endef
-
-  define Image/Build/grub
-       # left here because the image builder doesnt need these
-       $(INSTALL_DIR) $(KDIR)/root.grub/boot/grub
-       $(CP) \
-               $(KDIR)/stage1 \
-               $(KDIR)/stage2 \
-               $(KDIR)/e2fs_stage1_5 \
-               $(KDIR)/root.grub/boot/grub/
-       $(CP) $(KDIR)/bzImage $(KDIR)/root.grub/boot/vmlinuz
-       sed \
-               -e 's#@SERIAL_CONFIG@#$(strip $(GRUB_SERIAL_CONFIG))#g' \
-               -e 's#@TERMINAL_CONFIG@#$(strip $(GRUB_TERMINAL_CONFIG))#g' \
-               -e 's#@CMDLINE@#$(strip $(call Image/cmdline/$(1)) $(BOOTOPTS) $(GRUB_CONSOLE_CMDLINE))#g' \
-               -e 's#@TIMEOUT@#$(GRUB_TIMEOUT)#g' \
-               ./menu.lst > $(KDIR)/root.grub/boot/grub/menu.lst
-       PADDING="$(CONFIG_TARGET_IMAGES_PAD)" PATH="$(TARGET_PATH)" ./gen_image_x86.sh \
-               $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
-               $(CONFIG_TARGET_KERNEL_PARTSIZE) $(KDIR)/root.grub \
-               $(CONFIG_TARGET_ROOTFS_PARTSIZE) $(KDIR)/root.$(1)
-       $(call Image/Build/grub/$(1))
-  endef
-
-  define Image/Prepare/grub
-       # for the image builder
-       $(CP) \
-               $(STAGING_DIR)/usr/lib/grub/i386-openwrt/stage1 \
-               $(STAGING_DIR)/usr/lib/grub/i386-openwrt/stage2 \
-               $(STAGING_DIR)/usr/lib/grub/i386-openwrt/stage2_eltorito \
-               $(STAGING_DIR)/usr/lib/grub/i386-openwrt/e2fs_stage1_5 \
-               $(KDIR)/
-  endef
-
-endif
-
-ROOTDELAY=10
-
-ifneq ($(CONFIG_OLPC_BOOTSCRIPT_IMAGES),)
-
-  define Image/cmdline/ext4
-    root=$(ROOTPART) rootfstype=ext4 rootwait
-  endef
-
-  define Image/cmdline/jffs2-64k
-    block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=jffs2 rootdelay=$(ROOTDELAY)
-  endef
-
-  define Image/cmdline/jffs2-128k
-    block2mtd.block2mtd=$(ROOTPART),131072,rootfs root=/dev/mtdblock0 rootfstype=jffs2 rootdelay=$(ROOTDELAY)
-  endef
-
-  define Image/cmdline/squashfs
-    block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=squashfs rootdelay=$(ROOTDELAY)
-  endef
-
-  define Image/Build/bootscript
-       # left here because the image builder doesnt need these
-       $(INSTALL_DIR) $(KDIR)/root.bootscript/boot
-       $(CP) $(KDIR)/bzImage $(KDIR)/root.bootscript/boot/vmlinuz
-       sed -e 's#@CMDLINE@#$(strip $(call Image/cmdline/$(1))) $(BOOTOPTS)#g' \
-               ./olpc.fth > $(KDIR)/root.bootscript/boot/olpc.fth
-       PADDING="$(CONFIG_TARGET_IMAGES_PAD)" PATH="$(TARGET_PATH)" ./gen_image_olpc.sh \
-               $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
-               $(CONFIG_TARGET_KERNEL_PARTSIZE) $(KDIR)/root.bootscript \
-               $(CONFIG_TARGET_ROOTFS_PARTSIZE) $(KDIR)/root.$(1)
-  endef
+GRUB_TIMEOUT:=$(call qstrip,$(CONFIG_GRUB_TIMEOUT))
+GRUB_TITLE:=$(call qstrip,$(CONFIG_GRUB_TITLE))
 
-endif
+BOOTOPTS:=$(call qstrip,$(CONFIG_GRUB_BOOTOPTS))
 
-define Image/Build/squashfs
-       $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+define Build/combined
+       $(CP) $(KDIR)/$(KERNEL_NAME) $@.boot/boot/vmlinuz
+       -$(CP) $(STAGING_DIR_ROOT)/boot/. $@.boot/boot/
+       PADDING="$(CONFIG_TARGET_IMAGES_PAD)" SIGNATURE="$(IMG_PART_SIGNATURE)" $(SCRIPT_DIR)/gen_image_generic.sh \
+               $@ \
+               $(CONFIG_TARGET_KERNEL_PARTSIZE) $@.boot \
+               $(CONFIG_TARGET_ROOTFS_PARTSIZE) $(IMAGE_ROOTFS) \
+               256
 endef
 
-define Image/Build/iso 
-       $(INSTALL_DIR) $(KDIR)/root.grub/boot/grub
-       $(CP) \
-               $(KDIR)/stage2_eltorito \
-               $(KDIR)/root.grub/boot/grub/ 
+define Build/grub-config
+       rm -fR $@.boot
+       $(INSTALL_DIR) $@.boot/boot/grub
        sed \
                -e 's#@SERIAL_CONFIG@#$(strip $(GRUB_SERIAL_CONFIG))#g' \
                -e 's#@TERMINAL_CONFIG@#$(strip $(GRUB_TERMINAL_CONFIG))#g' \
-               -e 's#@CMDLINE@#$(strip $(call Image/cmdline/$(1)) $(BOOTOPTS) $(GRUB_CONSOLE_CMDLINE))#g' \
-               -e 's#(hd0,0)#(cd)#g' \
-               ./menu.lst > $(KDIR)/root.grub/boot/grub/menu.lst
-       $(CP) $(KDIR)/bzImage $(KDIR)/root.grub/boot/vmlinuz 
-       mkisofs -R -b boot/grub/stage2_eltorito -no-emul-boot -boot-load-size 4 -boot-info-table \
-               -o $(KDIR)/root.iso $(KDIR)/root.grub 
-endef 
-
-ifneq ($(CONFIG_X86_VDI_IMAGES),)
-  define Image/Build/vdi
-    # left here because the image builder doesnt need these
-    ifeq ($(1),ext4)
-               rm $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vdi || true
-               qemu-img convert -f raw -O vdi \
-                       $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
-                       $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vdi
-               # XXX: VBoxManage insists on setting perms to 0600
-               chmod 0644 $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vdi
-    endif
-  endef
-endif
+               -e 's#@ROOTPART@#root=$(ROOTPART) rootwait#g' \
+               -e 's#@CMDLINE@#$(BOOTOPTS) $(GRUB_CONSOLE_CMDLINE)#g' \
+               -e 's#@TIMEOUT@#$(GRUB_TIMEOUT)#g' \
+               -e 's#@TITLE@#$(GRUB_TITLE)#g' \
+               ./grub-$(1).cfg > $@.boot/boot/grub/grub.cfg
+endef
 
-ifneq ($(CONFIG_X86_VMDK_IMAGES),)
-  define Image/Build/vmdk
-    # left here because the image builder doesnt need these
-    ifeq ($(1),ext4)
-               rm $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vmdk || true
-               qemu-img convert -f raw -O vmdk \
-                       $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
-                       $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vmdk
-    endif
-  endef
-endif
+define Build/grub-install
+       rm -fR $@.grub2
+       $(INSTALL_DIR) $@.grub2
+       $(CP) $(STAGING_DIR_HOST)/lib/grub/i386-pc/*.img \
+               $(STAGING_DIR_HOST)/lib/grub/grub2-$(GRUB2_VARIANT)/core.img \
+               $@.grub2/
+       echo '(hd0) $@' > $@.grub2/device.map
+       $(STAGING_DIR_HOST)/bin/grub-bios-setup \
+               -m "$@.grub2/device.map" \
+               -d "$@.grub2" \
+               -r "hd0,msdos1" \
+               $@
+endef
 
-define Image/Build/gzip
-       gzip -f9 $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img
-       gzip -f9 $(BIN_DIR)/$(IMG_PREFIX)-rootfs-$(1).img
+define Build/iso
+       $(CP) $(KDIR)/$(KERNEL_NAME) $@.boot/boot/vmlinuz
+       cat \
+               $(STAGING_DIR_HOST)/lib/grub/i386-pc/cdboot.img \
+               $(STAGING_DIR_HOST)/lib/grub/grub2-iso/eltorito.img \
+               > $@.boot/boot/grub/eltorito.img
+       -$(CP) $(STAGING_DIR_ROOT)/boot/. $@.boot/boot/
+       mkisofs -R -b boot/grub/eltorito.img -no-emul-boot -boot-info-table \
+               -o $@ $@.boot $(TARGET_DIR)
 endef
 
-ifneq ($(CONFIG_TARGET_IMAGES_GZIP),)
-  define Image/Build/gzip/ext4
-       $(call Image/Build/gzip,ext4)
-  endef
-  ifneq ($(CONFIG_TARGET_IMAGES_PAD),)
-    define Image/Build/gzip/jffs2-64k
-       $(call Image/Build/gzip,jffs2-64k)
-    endef
-    define Image/Build/gzip/jffs2-128k
-       $(call Image/Build/gzip,jffs2-128k)
-    endef
+DEVICE_VARS += GRUB2_VARIANT
+define Device/Default
+  ARTIFACT/image.iso := grub-config iso | iso
+  IMAGES := combined.img.gz
+  IMAGE/combined.img.gz := append-rootfs | pad-extra 128k | grub-config pc | combined | grub-install | gzip
+  IMAGE/combined.vdi := append-rootfs | pad-extra 128k | grub-config pc | combined | grub-install | qemu-image vdi
+  IMAGE/combined.vmdk := append-rootfs | pad-extra 128k | grub-config pc | combined | grub-install | qemu-image vmdk
+  KERNEL := kernel-bin
+  KERNEL_INSTALL := 1
+  KERNEL_NAME := bzImage
+  ifeq ($(CONFIG_ISO_IMAGES),y)
+    ARTIFACTS := image.iso
   endif
-endif
-
-define Image/BuildKernel
-       $(CP) $(KDIR)/bzImage $(BIN_DIR)/$(IMG_PREFIX)-vmlinuz
-  ifneq ($(CONFIG_X86_ETHERBOOT_IMAGES),)
-       rm -f $(BIN_DIR)/$(IMG_PREFIX)-etherboot
-       $(STAGING_DIR_HOST)/bin/mkelfImage \
-               --append=$(CONFIG_X86_ETHERBOOT_BOOTOPTS) \
-               $(KDIR)/bzImage \
-               $(BIN_DIR)/$(IMG_PREFIX)-etherboot
+  ifeq ($(CONFIG_VDI_IMAGES),y)
+    IMAGES += combined.vdi
+  endif
+  ifeq ($(CONFIG_VMDK_IMAGES),y)
+    IMAGES += combined.vmdk
   endif
 endef
 
-define Image/Prepare
-       $(CP) $(LINUX_DIR)/arch/x86/boot/bzImage $(KDIR)/bzImage
-       $(call Image/Prepare/bootscript)
-       $(call Image/Prepare/grub)
-endef
+$(eval $(call Image/gzip-ext4-padded-squashfs))
 
-define Image/Build
-       $(call Image/Build/$(1))
-       $(call Image/Build/bootscript,$(1))
-  ifneq ($(1),iso)
-       $(call Image/Build/grub,$(1))
-       $(call Image/Build/vdi,$(1))
-       $(call Image/Build/vmdk,$(1))
-  endif
-       $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-rootfs-$(1).img
-       $(CP) $(KDIR)/bzImage $(BIN_DIR)/$(IMG_PREFIX)-vmlinuz
-       $(call Image/Build/gzip/$(1))
-endef
+ifeq ($(SUBTARGET),64)
+  include 64.mk
+endif
+
+ifeq ($(SUBTARGET),generic)
+  include generic.mk
+endif
+
+ifeq ($(SUBTARGET),legacy)
+  include legacy.mk
+endif
 
 $(eval $(call BuildImage))
+