x86: use $(strip) for the at_keyboard check
[openwrt/openwrt.git] / target / linux / x86 / image / Makefile
index a5f772251846661a6131eae93524ff7faf01cd36..e31734870f62707298ce8cb3b3ac27edb0c57fde 100644 (file)
@@ -18,7 +18,7 @@ GRUB_CONSOLE_CMDLINE =
 
 USE_ATKBD = generic kvm_guest
 
-ifneq ($(foreach subtarget,$(USE_ATKBD),$(CONFIG_TARGET_x86_$(subtarget))),)
+ifneq ($(strip $(foreach subtarget,$(USE_ATKBD),$(CONFIG_TARGET_x86_$(subtarget)))),)
   GRUB2_MODULES += at_keyboard
   GRUB2_MODULES_ISO += at_keyboard
 endif