x86: image: drop unneeded grub call
[openwrt/openwrt.git] / target / linux / x86 / image / Makefile
index 99887cb32b723bb35cf6257c3543b0c06984be1c..ef5b3c03c807b51c8a717c6dfaaf7943c3777d04 100644 (file)
@@ -68,6 +68,7 @@ ifneq ($(CONFIG_GRUB_IMAGES),)
        $(INSTALL_DIR) $(KDIR)/root.grub/boot/grub $(KDIR)/grub2
        $(CP) $(KDIR)/bzImage $(KDIR)/root.grub/boot/vmlinuz
        grub-mkimage \
+               -p /boot/grub \
                -d $(STAGING_DIR_HOST)/lib/grub/i386-pc \
                -o $(KDIR)/grub2/core.img \
                -O i386-pc \
@@ -92,12 +93,9 @@ ifneq ($(CONFIG_GRUB_IMAGES),)
                -d "$(KDIR)/grub2" \
                -r "hd0,msdos1" \
                "$(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img"
-       $(call Image/Build/grub/$(1))
   endef
 endif
 
-ROOTDELAY=10
-
 define Image/Build/squashfs
        dd if=/dev/zero bs=128k count=1 >> $(KDIR)/root.squashfs
 endef
@@ -106,6 +104,7 @@ define Image/Build/iso
        $(INSTALL_DIR) $(KDIR)/root.grub/boot/grub $(KDIR)/grub2
        $(CP) $(KDIR)/bzImage $(KDIR)/root.grub/boot/vmlinuz
        grub-mkimage \
+               -p /boot/grub \
                -d $(STAGING_DIR_HOST)/lib/grub/i386-pc \
                -o $(KDIR)/grub2/eltorito.img \
                -O i386-pc \