use immediate set in target Makefiles
[openwrt/openwrt.git] / target / linux / xburst / Makefile
index 3fd45fb790bb61cd8e42098f1ece5b279f04efea..2a64b7c46fa04b8693105d809469a050354bd751 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009-2010 OpenWrt.org
+# Copyright (C) 2009-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,17 +9,17 @@ include $(TOPDIR)/rules.mk
 ARCH:=mipsel
 BOARD:=xburst
 BOARDNAME:=Ingenic XBurst
-FEATURES:=jffs2 targz ubifs audio
-SUBTARGETS:=qi_lb60 n516 n526 id800wt
+FEATURES:=targz nand ubifs audio
+SUBTARGETS:=qi_lb60
 
-LINUX_VERSION:=2.6.35.7
+KERNEL_PATCHVER:=3.18
 
-DEVICE_TYPE=other
-
-include $(INCLUDE_DIR)/target.mk
+DEVICE_TYPE:=other
 
 define Target/Description
        Build firmware images for XBurst JZ47x0 based boards.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
 $(eval $(call BuildTarget))