mt76: update to the latest version
[openwrt/openwrt.git] / toolchain / binutils / Makefile
index f6889cb0e81ba24a927cd1a59584fb4c2acbecdc..b988598197606a3f34b8091a1fa5dc1fd829427f 100644 (file)
@@ -11,20 +11,20 @@ PKG_VERSION:=$(call qstrip,$(CONFIG_BINUTILS_VERSION))
 BIN_VERSION:=$(PKG_VERSION)
 
 PKG_SOURCE_URL:=@GNU/binutils/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 
 TAR_OPTIONS += --exclude='*.rej'
 
-ifeq ($(PKG_VERSION),2.27)
-  PKG_HASH:=369737ce51587f92466041a97ab7d2358c6d9e1b6490b3940eb09fb0a9a6ac88
-endif
-
 ifeq ($(PKG_VERSION),2.29.1)
-  PKG_HASH:=1509dff41369fb70aed23682351b663b56db894034773e6dbf7d5d6071fc55cc
+  PKG_HASH:=e7010a46969f9d3e53b650a518663f98a5dde3c3ae21b7d71e5e6803bc36b577
 endif
 
 ifeq ($(PKG_VERSION),2.30)
-  PKG_HASH:=efeade848067e9a03f1918b1da0d37aaffa0b0127a06b5e9236229851d9d0c09
+  PKG_HASH:=6e46b8aeae2f727a36f0bd9505e405768a72218f1796f0d09757d45209871ae6
+endif
+
+ifeq ($(PKG_VERSION),2.31.1)
+  PKG_HASH:=5d20086ecf5752cc7d9134246e9588fa201740d540f7eb84d795b1f7a93bca86
 endif
 
 ifneq ($(CONFIG_BINUTILS_VERSION_2_29_ARC),)