explicitly disable the use of ldconfig
[openwrt/openwrt.git] / toolchain / eglibc / Makefile
index f949f185aae787987a3b76a091e888609c4b492e..1e1031deb8db12c2c04a03adb4b50d0fb7a4d041 100644 (file)
@@ -36,6 +36,9 @@ endif
 ifneq ($(CONFIG_EGLIBC_VERSION_2_12),)
   PKG_SOURCE_URL:=svn://svn.eglibc.org/branches/eglibc-2_12
 endif
+ifneq ($(CONFIG_EGLIBC_VERSION_2_13),)
+  PKG_SOURCE_URL:=svn://svn.eglibc.org/branches/eglibc-2_13
+endif
 ifneq ($(CONFIG_EGLIBC_VERSION_TRUNK),)
   PKG_SOURCE_URL:=svn://svn.eglibc.org/trunk
 endif
@@ -52,15 +55,12 @@ HOST_STAMP_INSTALLED:=$(TOOLCHAIN_DIR)/stamp/.eglibc_installed
 HOST_BUILD_DIR1:=$(HOST_BUILD_DIR)-initial
 HOST_BUILD_DIR2:=$(HOST_BUILD_DIR)-final
 
-# XXX: {e,}glibc does not build w/ -Os
-# http://sourceware.org/bugzilla/show_bug.cgi?id=5203
-EGLIBC_CFLAGS:=$(subst -Os,-O2,$(TARGET_CFLAGS))
-
 EGLIBC_CONFIGURE:= \
        BUILD_CC="$(HOSTCC)" \
        $(TARGET_CONFIGURE_OPTS) \
        CFLAGS="$(EGLIBC_CFLAGS)" \
        libc_cv_slibdir="/lib" \
+       use_ldconfig=no \
        $(HOST_BUILD_DIR)/libc/configure \
                --prefix= \
                --build=$(GNU_HOST_NAME) \