Revert "[toolchain/eglibc} eglibc in fact can be built with -Os"
[openwrt/openwrt.git] / toolchain / eglibc / Makefile
index 5d34c95531523e524271783c00a60afea1608721..dec7ec3c11b9190d2d04ba50c66a5ed5b8818f99 100644 (file)
@@ -36,6 +36,9 @@ endif
 ifneq ($(CONFIG_EGLIBC_VERSION_2_12),)
   PKG_SOURCE_URL:=svn://svn.eglibc.org/branches/eglibc-2_12
 endif
+ifneq ($(CONFIG_EGLIBC_VERSION_2_13),)
+  PKG_SOURCE_URL:=svn://svn.eglibc.org/branches/eglibc-2_13
+endif
 ifneq ($(CONFIG_EGLIBC_VERSION_TRUNK),)
   PKG_SOURCE_URL:=svn://svn.eglibc.org/trunk
 endif
@@ -52,11 +55,16 @@ HOST_STAMP_INSTALLED:=$(TOOLCHAIN_DIR)/stamp/.eglibc_installed
 HOST_BUILD_DIR1:=$(HOST_BUILD_DIR)-initial
 HOST_BUILD_DIR2:=$(HOST_BUILD_DIR)-final
 
+# XXX: {e,}glibc does not build w/ -Os
+# http://sourceware.org/bugzilla/show_bug.cgi?id=5203
+EGLIBC_CFLAGS:=$(subst -Os,-O2,$(TARGET_CFLAGS))
+
 EGLIBC_CONFIGURE:= \
        BUILD_CC="$(HOSTCC)" \
        $(TARGET_CONFIGURE_OPTS) \
        CFLAGS="$(EGLIBC_CFLAGS)" \
        libc_cv_slibdir="/lib" \
+       use_ldconfig=no \
        $(HOST_BUILD_DIR)/libc/configure \
                --prefix= \
                --build=$(GNU_HOST_NAME) \