eglibc: disable NIS/SUNRPC by default. RPC support is provided by librpc
[openwrt/openwrt.git] / toolchain / gcc / common.mk
index 4970ccde8cf13d7a90ecdd54ffbe972e451d6234..1cd582cd3f27f53b91684b284f87f96155e97392 100644 (file)
@@ -38,10 +38,10 @@ ifdef CONFIG_GCC_VERSION_LLVM
 else
 ifeq ($(findstring linaro, $(CONFIG_GCC_VERSION)),linaro)
     ifeq ($(CONFIG_GCC_VERSION),"4.5-linaro")
-      PKG_REV:=4.5-2012.02
+      PKG_REV:=4.5-2012.03
       PKG_VERSION:=4.5.4
       PKG_VERSION_MAJOR:=4.5
-      PKG_MD5SUM:=e05be9ea8eca2ad4c859d35dbab568e7
+      PKG_MD5SUM:=0c25f93e15e362e352c933e4649a7fc6
     endif
     ifeq ($(CONFIG_GCC_VERSION),"4.6-linaro")
       PKG_REV:=4.6-2012.10
@@ -50,10 +50,10 @@ ifeq ($(findstring linaro, $(CONFIG_GCC_VERSION)),linaro)
       PKG_MD5SUM:=acd304caf055ccaaca4e3ef61da11e7d
     endif
     ifeq ($(CONFIG_GCC_VERSION),"4.7-linaro")
-      PKG_REV:=4.7-2012.04
-      PKG_VERSION:=4.7.1
+      PKG_REV:=4.7-2012.10
+      PKG_VERSION:=4.7.3
       PKG_VERSION_MAJOR:=4.7
-      PKG_MD5SUM:=6dab459c1177fc9ae2969e7a39549d44
+      PKG_MD5SUM:=a5ca87667350f1395d4da40c94ef059c
     endif
     PKG_SOURCE_URL:=http://launchpad.net/gcc-linaro/$(PKG_VERSION_MAJOR)/$(PKG_REV)/+download/
     PKG_SOURCE:=$(PKG_NAME)-linaro-$(PKG_REV).tar.bz2
@@ -69,9 +69,15 @@ else
   ifeq ($(PKG_VERSION),4.6.2)
     PKG_MD5SUM:=028115c4fbfb6cfd75d6369f4a90d87e
   endif
+  ifeq ($(PKG_VERSION),4.6.3)
+    PKG_MD5SUM:=773092fe5194353b02bb0110052a972e
+  endif
   ifeq ($(PKG_VERSION),4.7.0)
     PKG_MD5SUM:=2a0f1d99fda235c29d40b561f81d9a77
   endif
+  ifeq ($(PKG_VERSION),4.7.2)
+    PKG_MD5SUM:=cc308a0891e778cfda7a151ab8a6e762
+  endif
 endif
 endif