toolchain/gdb: fix compilation with ccache
[openwrt/openwrt.git] / toolchain / gdb / Makefile
index bc2cab90c3efffea5b6dbd8e2bf6f6642b96ba9b..05e3c7de3c3d9fec0b0fee0891c20b25c62b35d7 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2016 OpenWrt.org
+# Copyright (C) 2006-2020 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,23 +7,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gdb
-
-ifeq ($(CONFIG_arc),y)
-PKG_VERSION:=arc-2016.03-gdb
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://github.com/foss-for-synopsys-dwc-arc-processors/binutils-gdb/archive/arc-2016.03-gdb
-PKG_MD5SUM:=775caaf6385c16f20b6f53c0a2b95f79
-GDB_DIR:=binutils-$(PKG_NAME)-$(PKG_VERSION)
-PATCH_DIR:=./patches-arc
-else
-PKG_VERSION:=7.11.1
+PKG_VERSION:=10.1
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/gdb
-PKG_MD5SUM:=5aa71522e488e358243917967db87476
+PKG_HASH:=f82f1eceeec14a3afa2de8d9b0d3c91d5a3820e23e0a01bbb70ef9f0276b62c0
 GDB_DIR:=$(PKG_NAME)-$(PKG_VERSION)
-endif
 
 HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(GDB_DIR)
 
@@ -32,6 +22,7 @@ HOST_BUILD_PARALLEL:=1
 include $(INCLUDE_DIR)/toolchain-build.mk
 
 HOST_CONFIGURE_VARS += \
+       acx_cv_cc_gcc_supports_ada=false \
        gdb_cv_func_sigsetjmp=yes
 
 HOST_CONFIGURE_ARGS = \
@@ -41,11 +32,13 @@ HOST_CONFIGURE_ARGS = \
        --target=$(REAL_GNU_TARGET_NAME) \
        --disable-werror \
        --without-uiout \
-       --disable-tui --disable-gdbtk --without-x \
+       --enable-tui --disable-gdbtk --without-x \
        --without-included-gettext \
        --enable-threads \
        --with-expat \
        --without-python \
+       --disable-unit-tests \
+       --disable-ubsan \
        --disable-binutils \
        --disable-ld \
        --disable-gas \