toolchain/nasm: force ar and ranlib only on macOSX
[openwrt/openwrt.git] / toolchain / nasm / Makefile
index 8d071033c7dc5ba08aa50520f1663541a5051035..31166358fd963ec01240bf8a4b97d65b7ce4cbc0 100644 (file)
@@ -24,9 +24,11 @@ HOST_CONFIGURE_ARGS+= \
                --disable-gdb \
                $(SOFT_FLOAT_CONFIG_OPTION) \
 
                --disable-gdb \
                $(SOFT_FLOAT_CONFIG_OPTION) \
 
-HOST_MAKE_FLAGS = \
-       AR=ar \
-       RANLIB=ranlib
+ifeq ($(HOST_OS),Darwin)
+       HOST_MAKE_FLAGS = \
+               AR=ar \
+               RANLIB=ranlib
+endif
 
 define Host/Prepare
        $(call Host/Prepare/Default)
 
 define Host/Prepare
        $(call Host/Prepare/Default)