fix compile errors with make 3.80
[openwrt/openwrt.git] / tools / Makefile
index 513ecccb5197db32c2867b8cecbb12ad4636c7b1..2c093c0aaca67b578a21f01bc72f1038af192150 100644 (file)
@@ -1,60 +1,35 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # Main makefile for the host tools
 #
-include $(TOPDIR)/rules.mk
-TARGETS-y:=sed sstrip ipkg-utils ext2fs squashfs mtd-utils lzma mkimage firmware-utils
-TARGETS-$(CONFIG_CCACHE) += ccache
 
-TARGETS_DOWNLOAD:=$(patsubst %,%-download,$(TARGETS-y))
-TARGETS_PREPARE:=$(patsubst %,%-prepare,$(TARGETS-y))
-TARGETS_COMPILE:=$(patsubst %,%-compile,$(TARGETS-y))
-TARGETS_INSTALL:=$(patsubst %,%-install,$(TARGETS-y))
-TARGETS_CLEAN:=$(patsubst %,%-clean,$(TARGETS-y))
-STAMP:=$(STAGING_DIR)/stampfiles/.tools_installed
+file:=${lastword ${MAKEFILE_LIST}}
+curdir:=tools
 
-all: install
-download: $(TARGETS_DOWNLOAD)
-compile: $(TARGETS_COMPILE)
-install: $(STAMP)
-clean: $(TARGETS_CLEAN)
+# subdirectories to descend into
+$(curdir)/builddirs := sed sstrip ipkg-utils ext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline $(if $(CONFIG_CCACHE),ccache)
 
-squashfs-compile: lzma-install
+# builddir dependencies
+$(curdir)/squashfs/compile := $(curdir)/lzma/install
 
-ifneq ($(shell $(SCRIPT_DIR)/timestamp.pl -p . $(STAMP)),$(STAMP))
-  $(STAMP): $(TARGETS_INSTALL)
-endif
+# preparatory work
+define copy_include
+$(STAGING_DIR)/include-host/.done:
+       @mkdir -p $$$$(dirname $$@)
+       @cp $(1)/include/*.h $$$$(dirname $$@)/
+       @touch $$@
+$(curdir)//prepare = $(STAGING_DIR)/include-host/.done
+endef
+$(eval $(call copy_include,$(curdir)))
 
-$(STAMP): $(TOPDIR)/.config
-       mkdir -p $(shell dirname $@)
-       touch $@
+# prerequisites for the individual targets
+$(curdir)/ := .config
+$(curdir)//compile = $(1)/prepare
+$(curdir)//install = $(1)/compile
 
-TOOL_HOST_INCLUDES:=$(patsubst ./include/%.h,$(STAGING_DIR)/include-host/%.h,$(wildcard ./include/*.h))
-$(TOOL_HOST_INCLUDES): $(STAGING_DIR)/include-host/%.h: ./include/%.h
-       @mkdir -p $(STAGING_DIR)/include-host
-       $(CP) $< $@
-
-$(TOOL_BUILD_DIR):
-       @mkdir -p $@
-
-%-prereq %-download %-clean: FORCE
-       $(MAKE) -C $* $(patsubst $*-%,%,$@)
-
-%-prepare: $(TOOL_HOST_INCLUDES) $(TOOL_BUILD_DIR) FORCE
-       $(MAKE) -C $* $(patsubst $*-%,%,$@)
-
-%-compile: %-prepare FORCE
-       $(MAKE) -C $* $(patsubst $*-%,%,$@)
-       
-%-install: %-compile FORCE
-       $(MAKE) -C $* $(patsubst $*-%,%,$@)
-
-ifeq ($(MAKECMDGOALS),install-targets)
-MAKEFLAGS:=$(MAKEFLAGS) -j$(CONFIG_JLEVEL)
-else
-.NOTPARALLEL:
-endif
+$(eval $(call stampfile,$(curdir),tools))
+$(eval $(call subdir,$(curdir)))