fix the cpu_wait patch for 2.6.22
[openwrt/openwrt.git] / tools / Makefile
index 513ecccb5197db32c2867b8cecbb12ad4636c7b1..68e7dab534f0ce6f6aef3563aa20baabad20136f 100644 (file)
@@ -7,7 +7,7 @@
 # Main makefile for the host tools
 #
 include $(TOPDIR)/rules.mk
-TARGETS-y:=sed sstrip ipkg-utils ext2fs squashfs mtd-utils lzma mkimage firmware-utils
+TARGETS-y:=sed sstrip ipkg-utils ext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline
 TARGETS-$(CONFIG_CCACHE) += ccache
 
 TARGETS_DOWNLOAD:=$(patsubst %,%-download,$(TARGETS-y))
@@ -41,7 +41,7 @@ $(TOOL_HOST_INCLUDES): $(STAGING_DIR)/include-host/%.h: ./include/%.h
 $(TOOL_BUILD_DIR):
        @mkdir -p $@
 
-%-prereq %-download %-clean: FORCE
+%-prereq %-download %-clean %-refresh %-update: FORCE
        $(MAKE) -C $* $(patsubst $*-%,%,$@)
 
 %-prepare: $(TOOL_HOST_INCLUDES) $(TOOL_BUILD_DIR) FORCE