reorder dependencies
[openwrt/openwrt.git] / tools / Makefile
index 4a39663cdb0dfebfe4d54d01b01789e7f19b03b1..c8523832414d947642458b023eb69d398f677ffd 100644 (file)
@@ -17,12 +17,13 @@ endif
 tools-y += m4 autoconf automake bison pkg-config sed mklibs
 tools-y += sstrip ipkg-utils genext2fs e2fsprogs mtd-utils mkimage
 tools-y += firmware-utils patch-cmdline quilt yaffs2 flock
+tools-y += xorg-macros xz
 tools-$(CONFIG_TARGET_orion_generic) += wrt350nv2-builder upslug2
 tools-$(CONFIG_TARGET_x86) += qemu
 ifneq ($(CONFIG_TARGET_ar71xx),)
-tools-y += squashfs lzma-old
+tools-y += lzma-old squashfs 
 endif
-tools-y += squashfs4 lzma
+tools-y += lzma squashfs4
 tools-$(CONFIG_CCACHE) += ccache
 
 ifdef CONFIG_GCC_USE_GRAPHITE
@@ -39,13 +40,15 @@ $(curdir)/squashfs4/compile := $(curdir)/lzma/install
 $(curdir)/quilt/compile := $(curdir)/sed/install $(curdir)/autoconf/install
 $(curdir)/dtc/compile := $(curdir)/bison/install
 $(curdir)/autoconf/compile := $(curdir)/m4/install
-$(curdir)/automake/compile := $(curdir)/m4/install $(curdir)/autoconf/install
+$(curdir)/automake/compile := $(curdir)/m4/install $(curdir)/autoconf/install $(curdir)/pkg-config/install
 $(curdir)/mpc/compile := $(curdir)/gmp/install
 $(curdir)/mpfr/compile := $(curdir)/gmp/install
 $(curdir)/mtd-utils/compile := $(curdir)/e2fsprogs/install
 $(curdir)/mkimage/compile := $(curdir)/sed/install
 $(curdir)/qemu/compile := $(curdir)/e2fsprogs/install
 $(curdir)/upslug2/compile := $(curdir)/automake/install
+$(curdir)/xorg-macros/compile := $(curdir)/automake/install
+$(curdir)/mpfr/compile := $(curdir)/automake/install
 
 $(curdir)/builddirs := $(tools-y) $(tools-dep) $(tools-)
 $(curdir)/builddirs-default := $(tools-y)
@@ -61,11 +64,8 @@ define PrepareStaging
 endef
 
 # preparatory work
-$(STAGING_DIR)/.prepared: $(TMP_DIR)/.build $(STAGING_DIR_HOST)/.prepared
+$(STAGING_DIR)/.prepared: $(TMP_DIR)/.build
        $(call PrepareStaging,$(STAGING_DIR))
-       mkdir -p $(STAGING_DIR)/host/share
-       rm -rf $(STAGING_DIR)/host/share/aclocal
-       ln -s $(STAGING_DIR_HOST)/share/aclocal $(STAGING_DIR)/host/share/
        mkdir -p $(BUILD_DIR)/stamp
        touch $@