autoconf: portability fixes
[openwrt/openwrt.git] / tools / autoconf / Makefile
index ec154e46471e9f3a211b8fc200ca1959f29aacb2..c45855c03d5a877ee6523ab91cd2a6501b60a2e0 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006-2014 OpenWrt.org
+# Copyright (C) 2006-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -15,11 +15,11 @@ PKG_MD5SUM:=50f97f4159805e374639a73e2636f22e
 
 include $(INCLUDE_DIR)/host-build.mk
 
-define Host/Configure
-       $(call Host/Configure/Default,\
-               --datarootdir=$(STAGING_DIR_HOST)/share \
-       )
-endef
+HOST_CONFIGURE_ARGS += \
+       --datarootdir=$(STAGING_DIR_HOST)/share
+
+HOST_CONFIGURE_VARS += \
+       PERL="/usr/bin/env perl"
 
 define Host/Compile
        export SHELL="$(BASH)"; $(MAKE) -C $(HOST_BUILD_DIR)