automake: update to 1.11.6
[openwrt/openwrt.git] / tools / automake / Makefile
index cd258479df8723b1b951f84581e37adfdab8f76d..546f9b26619f272af9e65ce971ae54aa9de610ca 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,29 +7,25 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=automake
-PKG_VERSION:=1.9.6
+PKG_VERSION:=1.11.6
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/automake
-PKG_MD5SUM:=c11b8100bb311492d8220378fd8bf9e0
+PKG_MD5SUM:=cf4752287ad708f83bd3689da57a32c9
 
 include $(INCLUDE_DIR)/host-build.mk
 
-define Host/Configure
-       $(call Host/Configure/Default,\
-               --datarootdir=$(STAGING_DIR_HOST)/share \
-       )
-endef
-
-define Host/Compile
-       $(MAKE) -C $(HOST_BUILD_DIR)
-endef
+HOST_CONFIGURE_ARGS += --datarootdir=$(STAGING_DIR_HOST)/share
+HOST_CONFIGURE_VARS += am_cv_prog_PERL_ithreads=no
 
 define Host/Install
        $(MAKE) -C $(HOST_BUILD_DIR) install
        mv $(STAGING_DIR_HOST)/bin/aclocal $(STAGING_DIR_HOST)/bin/aclocal.real
        $(INSTALL_BIN) ./files/aclocal $(STAGING_DIR_HOST)/bin
-       ln -f $(STAGING_DIR_HOST)/bin/aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.9
+       ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.9
+       ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.10
+       ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.11
+       ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.11.6
 endef
 
 define Host/Clean