tools/ccache: update to 3.5
[openwrt/openwrt.git] / tools / ccache / Makefile
index a0f6332522722f2bc08971143b13bf02191373e9..175cb11bdf35eed1ec398e5406dfb10c7ddc7cde 100644 (file)
@@ -8,11 +8,12 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/target.mk
 
 PKG_NAME:=ccache
-PKG_VERSION:=3.1.11
+PKG_VERSION:=3.5
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_SOURCE_URL:=http://samba.org/ftp/ccache/
-PKG_MD5SUM:=0f6df80c8941d9020a1fd5df5ad57dd7
+PKG_SOURCE_URL:=https://download.samba.org/pub/ccache/ \
+               https://samba.org/ftp/ccache/
+PKG_HASH:=bdd44b72ae4506a2e2deef9fefb15c606a474bbca7658cd2be26105155eec012
 
 include $(INCLUDE_DIR)/host-build.mk
 
@@ -23,29 +24,13 @@ define Host/Install/ccache
        $(CP) ./files/* $(STAGING_DIR_HOST)/bin/
 endef
 
-ifneq ($(strip $(shell which ccache >/dev/null && echo found)),found)
-  define Host/Clean
+define Host/Clean
        -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
        $(call Host/Clean/Default)
-  endef
-  define Host/Install
+endef
+define Host/Install
        $(call Host/Install/Default)
        $(call Host/Install/ccache)
-  endef
-else
-  define Host/Prepare
-  endef
-  define Host/Configure
-  endef
-  define Host/Compile
-  endef
-  define Host/Install
-       $(call Host/Install/ccache)
-  endef
-  define Host/Clean
-  endef
-  define Download
-  endef
-endif
+endef
 
 $(eval $(call HostBuild))