ccache does not need zcat
[openwrt/openwrt.git] / tools / ccache / Makefile
index 9bc0b5901a5013bef55aefbd5e6438b54afb4010..442094a180cb3795ff9cce311405143a543258ed 100644 (file)
@@ -13,10 +13,14 @@ PKG_VERSION:=3.1.7
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://samba.org/ftp/ccache/
 PKG_MD5SUM:=80a698c22d0b06b19c88ac58e8d8b632
-PKG_CAT:=zcat
 
 include $(INCLUDE_DIR)/host-build.mk
 
+define Host/Install/ccache
+       $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin/
+       $(CP) ./files/* $(STAGING_DIR_HOST)/bin/
+endef
+
 ifneq ($(strip $(shell which ccache >/dev/null && echo found)),found)
   define Host/Compile
        $(MAKE) CC="$(HOSTCC_NOCACHE)" -C $(HOST_BUILD_DIR)
@@ -26,6 +30,10 @@ ifneq ($(strip $(shell which ccache >/dev/null && echo found)),found)
        -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
        $(call Host/Clean/Default)
   endef
+  define Host/Install
+       $(call Host/Install/Default)
+       $(call Host/Install/ccache)
+  endef
 else
   define Host/Prepare
   endef
@@ -34,6 +42,7 @@ else
   define Host/Compile
   endef
   define Host/Install
+       $(call Host/Install/ccache)
   endef
   define Host/Clean
   endef