add ccache wrapper
[openwrt/openwrt.git] / tools / ccache / Makefile
index 21123b316db45d32f89b70ec7231b43e698b37bd..8848fa5102b2500deaa5b3207bcf35a9bbfc64a2 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,15 +8,20 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/target.mk
 
 PKG_NAME:=ccache
-PKG_VERSION:=3.1.3
+PKG_VERSION:=3.1.7
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://samba.org/ftp/ccache/
-PKG_MD5SUM:=b952d75e9ca37209d608ea58d84135cd
+PKG_MD5SUM:=80a698c22d0b06b19c88ac58e8d8b632
 PKG_CAT:=zcat
 
 include $(INCLUDE_DIR)/host-build.mk
 
+define Host/Install/ccache
+       $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin/
+       $(CP) ./files/* $(STAGING_DIR_HOST)/bin/
+endef
+
 ifneq ($(strip $(shell which ccache >/dev/null && echo found)),found)
   define Host/Compile
        $(MAKE) CC="$(HOSTCC_NOCACHE)" -C $(HOST_BUILD_DIR)
@@ -26,6 +31,10 @@ ifneq ($(strip $(shell which ccache >/dev/null && echo found)),found)
        -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
        $(call Host/Clean/Default)
   endef
+  define Host/Install
+       $(call Host/Install/Default)
+       $(call Host/Install/ccache)
+  endef
 else
   define Host/Prepare
   endef
@@ -34,6 +43,7 @@ else
   define Host/Compile
   endef
   define Host/Install
+       $(call Host/Install/ccache)
   endef
   define Host/Clean
   endef