tools/cmake: refresh patches
[openwrt/openwrt.git] / tools / cmake / patches / 120-curl-fix-libressl-linking.patch
index e217979ee42f2f61d020462758d29e7d829bbcd8..6ef37c22cb2531de284f7a1154ccdf5c0321771d 100644 (file)
@@ -20,10 +20,10 @@ Signed-off-by: Jo-Philipp Wich <jo@mein.io>
 ---
 --- a/Utilities/cmcurl/CMakeLists.txt
 +++ b/Utilities/cmcurl/CMakeLists.txt
-@@ -454,6 +454,14 @@ if(CMAKE_USE_OPENSSL)
+@@ -594,6 +594,14 @@ if(CURL_USE_OPENSSL)
+   endif()
+   set(SSL_ENABLED ON)
    set(USE_OPENSSL ON)
-   set(HAVE_LIBCRYPTO ON)
-   set(HAVE_LIBSSL ON)
 +  check_library_exists("rt" clock_gettime "" HAVE_LIBRT)
 +  if(HAVE_LIBRT)
 +    list(APPEND OPENSSL_LIBRARIES rt)