tools/dosfstools: Update to 4.1
[openwrt/openwrt.git] / tools / dosfstools / Makefile
index 5a5bd1d4b9b44aab645b9425c7bbcbeabc3de4a7..861dcbf1c74932f318fc2edfec18741eab3c7d6e 100644 (file)
@@ -1,5 +1,6 @@
 #
 # Copyright (C) 2012-2015 OpenWrt.org
+# Copyright (C) 2016 LEDE-Project.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,33 +8,19 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dosfstools
-PKG_VERSION:=3.0.27
+PKG_VERSION:=4.1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=git://github.com/dosfstools/dosfstools.git
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_VERSION:=266a5fc635135a9ffaa8683da1ec03aae1553b7b
-PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=https://github.com/dosfstools/dosfstools/releases/download/v$(PKG_VERSION)/ \
+               http://fossies.org/linux/misc
+PKG_HASH:=e6b2aca70ccc3fe3687365009dd94a2e18e82b688ed4e260e04b7412471cc173
 
-HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)-$(PKG_VERSION)
+HOST_FIXUP:=autoreconf
 
 include $(INCLUDE_DIR)/host-build.mk
 
 ifeq ($(HOST_OS),Darwin)
-LDLIBS += -liconv
+HOST_CFLAGS += -UHAVE_ENDIAN_H
 endif
 
-define Host/Compile
-       $(MAKE) -C $(HOST_BUILD_DIR) SHELL="$(BASH)" LDFLAGS="$(HOST_LDFLAGS)" LDLIBS="$(LDLIBS)"
-endef
-
-define Host/Install
-       $(INSTALL_BIN) $(HOST_BUILD_DIR)/mkfs.fat $(STAGING_DIR_HOST)/bin/
-       $(LN) mkfs.fat $(STAGING_DIR_HOST)/bin/mkdosfs
-endef
-
-define Host/Clean
-       rm -f $(STAGING_DIR_HOST)/bin/mk{dosfs,fs.fat}
-endef
-
 $(eval $(call HostBuild))