tools: improve and simplify dosfstools
[openwrt/openwrt.git] / tools / dosfstools / Makefile
index c87d800b8533547fc0e22327c870771992a83e16..86589e6d7dc4f841980659aa0422e9d7ad18a8ff 100644 (file)
@@ -15,21 +15,10 @@ PKG_SOURCE_URL:=https://github.com/dosfstools/dosfstools/releases/download/v$(PK
                http://fossies.org/linux/misc
 PKG_MD5SUM:=9037738953559d1efe04fc5408b6846216cc0138f7f9d32de80b6ec3c35e7daf
 
                http://fossies.org/linux/misc
 PKG_MD5SUM:=9037738953559d1efe04fc5408b6846216cc0138f7f9d32de80b6ec3c35e7daf
 
-HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)-$(PKG_VERSION)
-
 include $(INCLUDE_DIR)/host-build.mk
 
 ifeq ($(HOST_OS),Darwin)
 HOST_CFLAGS += -UHAVE_ENDIAN_H
 include $(INCLUDE_DIR)/host-build.mk
 
 ifeq ($(HOST_OS),Darwin)
 HOST_CFLAGS += -UHAVE_ENDIAN_H
-LDLIBS += -liconv
 endif
 
 endif
 
-define Host/Install
-       $(INSTALL_BIN) $(HOST_BUILD_DIR)/src/mkfs.fat $(STAGING_DIR_HOST)/bin/
-endef
-
-define Host/Clean
-       rm -f $(STAGING_DIR_HOST)/bin/mk{dosfs,fs.fat}
-endef
-
 $(eval $(call HostBuild))
 $(eval $(call HostBuild))