e2fsprogs: update to 1.42.3
[openwrt/openwrt.git] / tools / e2fsprogs / Makefile
index 893fcf421f3f393cdbf1f5810695b9f38a03ba76..865ed9fb44138b4ccd124e52842f5950f6083b36 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,8 +8,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=e2fsprogs
-PKG_VERSION:=1.41.12
-PKG_MD5SUM:=1b24a21fc0c2381ef420961cbfec733f
+PKG_VERSION:=1.42.3
+PKG_MD5SUM:=73431146f58d40fe1375aba2060f0da8
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -30,6 +30,9 @@ CONFIGURE_ARGS += \
 define Host/Install
        $(Host/Install/Default)
        $(MAKE) -C $(HOST_BUILD_DIR)/lib/uuid install
+       mkdir -p $(STAGING_DIR_HOST)/include/e2fsprogs
+       $(CP) $(STAGING_DIR_HOST)/include/uuid $(STAGING_DIR_HOST)/include/e2fsprogs/
+       rm -rf $(STAGING_DIR_HOST)/include/uuid
        $(INSTALL_DATA) $(HOST_BUILD_DIR)/lib/uuid/libuuid.a $(STAGING_DIR_HOST)/lib/
 endef